Android 'Debug activé périphérique ne s'affiche pas sur Eclipse

Je suis passé par beaucoup de discussions avant de poster cela ici. Je suis confronté à un problème avec appareil Android débogage - l'appareil n'est pas répertorié sur l'onglet Périphériques dans l'IDE Eclipse. (Pour obtenir des "Appareils" de l'onglet "Windows -> Show view -> Appareils"). Ainsi, alors que de commencer à déboguer il n'y a aucun moyen de choisir un appareil dans la liste des périphériques affiche vide. La chose étrange est que ça marchait bien avant et sous l'explorateur windows, je peux parcourir les fichiers.

Je suis avec Windows Vista Home premium 32-bit OS

Ce que tout ce que j'ai essayé:

Au téléphone:

  • Débogage USB est activé sur votre téléphone, sous " Paramètres-> Développeur
    options
  • Désactivé et activé le débogage USB
  • Redémarré le téléphone

Dans Eclipse:

  • Sous 'Debug configurations->Cible(onglet)', 'Toujours demander de choisir
    l'appareil " est sélectionné. Il demande, mais ne montrent aucun appareil sur le
    liste des périphériques!
  • Essayé de repos de la BAD en vertu de l'onglet Périphériques. (Pour obtenir des "Appareils" de l'onglet 'Windows
    -> Show view -> Appareils
  • Réinstallé le dernier Android SDK avec la BAD
  • Installé Eclipse Juno

Dans windows CMD sous /platform-tools/répertoire où le Android SDK Tools est installé, couru les commandes suivantes sans obtenir aucun résultat positif:
L'arrêt de l'Éclipse, débranché l'appareil et essayé de lancer:
adb kill-server
adb start-server

Branché, il est de retour et a couru
bad appareils

Appareil Mobile détails:

  • Modèle = Galaxy S2 GT-i9100
  • Enracinée = oui
  • OS Ver. = 4.0.3
  • Noyau ver. = 3.0.15
  • hardcore@speedmod-s2-ics #k3-27b

    Eclipse version: Indigo Service Release 1
    Build id: 20110916-0149

Edit1: je suis à la fin jusqu'à obtenir ce message d'erreur sur l'Éclipse de la console:
"[2012-10-09 12:39:22 - DeviceMonitor] Bad Erreur de connexion:Une connexion existante a dû être fermée par l'hôte distant
[2012-10-09 12:39:23 - DeviceMonitor] les tentatives de Connexion: 1"
Je crois que le problème est avec la BAD pilote. J'ai installé la dernière version du SDK de sorte que le conducteur est également plus tard. Est-il un autre moyen pour installer le pilote ADB?

  • J'Espère this va aider tout le monde qui est en face d'un même problème.
InformationsquelleAutor ambar | 2012-10-09