Comment faire pour installer des pandas pour Python 3?

J'essaie d'installer les pandas pour Python 3 en exécutant la commande suivante:

sudo pip3 install pandas

Comme un résultat que j'obtient ceci:

Downloading/unpacking pandas
  Cannot fetch index base URL https://pypi.python.org/simple/
  Could not find any downloads that satisfy the requirement pandas
Cleaning up...
No distributions at all found for pandas

Peut-être qu'il est intéressant de noter que l'installation de Python 2 fonctionne très bien.

sudo pip install pandas

Renvoie les éléments suivants:

Requirement already satisfied (use --upgrade to upgrade): pandas in /usr/lib/python2.7/dist-packages
Requirement already satisfied (use --upgrade to upgrade): python-dateutil in /usr/lib/python2.7/dist-packages (from pandas)
Requirement already satisfied (use --upgrade to upgrade): pytz>=2011k in /usr/lib/python2.7/dist-packages (from pandas)
Requirement already satisfied (use --upgrade to upgrade): numpy>=1.6.1 in /usr/lib/python2.7/dist-packages (from pandas)
Cleaning up...

AJOUTÉ

Je viens d'installer les pandas de la manière suivante:

sudo apt-get install python3-pandas
  • Qu'advient-il si vous essayez sudo python3 -m pip install pandas ? Je trouve pip3 à se comporter drôle parfois.
  • J'ai installé pip3 via brew et pip3 install pandas fonctionne comme un charme. Votre problème est probablement dépend de la distribution lequel utilisez-vous?
InformationsquelleAutor Roman | 2016-08-04