Erreur lors de l'installation gem capybara-webkit

Je suis nouveau à ruby, mais tout en essayant d'installer le capybara pour exécuter le test sur mon système j'obtiens l'erreur suivante. Im OSX

my_app$ gem install capybara-webkit
Building native extensions.  This could take a while...
ERROR:  Error installing capybara-webkit:
ERROR: Failed to build gem native extension.

/Users/joe/.rvm/rubies/ruby-1.9.2-p290/bin/ruby extconf.rb

Gem files will remain installed in /Users/joe/.rvm/gems/ruby-1.9.2-p290/gems/capybara-webkit-0.7.2 for inspection.
Results logged to /Users/joe/.rvm/gems/ruby-1.9.2-p290/gems/capybara-webkit-0.7.2/./gem_make.out

voici les résultats de gem_make.hors

/Users/joe/.rvm/rubies/ruby-1.9.2-p290/bin/ruby extconf.rb
  • Pouvez-vous montrer ce que gem_make.out fichier dit? J'ai eu un problème avec l'installation de capybara-webkit récemment et ce qui m'a aidé a été de réinstaller libqt4-dev paquet sur Ubuntu. Pas sûr de ce qui est l'équivalent sur OSX, mais peut-être que vous manquez quelque qt dépendances trop.
  • Avez-vous installé Qt?
  • Je suis nouveau sur les rails. Je ne sais pas ce que Qt est, je suis à la recherche pour elle maintenant à installer. merci Marc
InformationsquelleAutor eiu165 | 2011-12-03