ObjectAnimator de l'API de Niveau < 11

Donc je suis vraiment frustré avec android et le fait la moitié du truc ne fonctionne pas lorsque vous revenez Niveau de l'API passé 11. Pourquoi n'est-il pas facile et bien fait comme iOS?!

Le Problème
Je suis à l'aide de ObjectAnimators pour animer la transition entre Fragments. Qu'ils fonctionnent très bien dans quoi que ce soit avec l'API de Niveau 11 et ci-dessus. Dès que j'ai du changer la cible de construction à moins de 11 ans, j'ai eu des problèmes avec elle, en disant qu'il ne peut pas trouvé des identifiants de ressource pour les attributs tels que la propertyName et valueType dans le fichier xml.

La Question
Que dois-je utiliser à la place pour animer mon Fragment transitions qui vont travailler sur l'API Niveaux > 7.

Merci d'avance.

  • Property Animation Introduit dans Android 3.0 (API de niveau 11).
  • Désolé pour le noob de la requête. Je comprends que nous ne pouvons pas construire de pré-3.0, mais cela veut-il aussi dire que les animations à l'aide de la Propriété de l'animation (sur une application construite à l'aide 4.4) ne fonctionnera pas sur les dispositifs de pré-3.0 ?
InformationsquelleAutor StuStirling | 2012-07-24